PAT甲级 1008 Elevator(20) (模拟)

题目

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

输入

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

输出

For each test case, print the total time on a single line.

样例输入 

3 2 3 1

样例输出 

41

题意理解

给你n个楼层,你初始是在第0层,你往上一层需要花费的时间6秒,往下是花费4秒,每层楼到了以后会停留五秒,计算你最后花费了多少时间。那么我们根据题意模拟一下即可。注意到达最后一个楼层以后不需要回来。

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=110;
int a[N];
int n;
int main(){
    cin>>n;
    for(int i=0;i<n;i++)cin>>a[i];
    int res=0;
    int lay=0;
    for(int i=0;i<n;i++){
        if(a[i]>lay){
            res+=6*(a[i]-lay)+5;
            lay=a[i];
        }
        else if(a[i]<lay) {
            res+=4*(lay-a[i])+5;
            lay=a[i];
        }
        else if (a[i]==lay){
            res+=5;
        }
    }
    cout<<res<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值