PAT 甲级 1008 Elevator

PAT 甲级 1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1
结尾无空行

Sample Output:

41
结尾无空行
题意描述:

有一个电梯,按顺序给出N个楼层,给出电梯每上升一层的时间、每下降一层的时间以及在N个楼层停留的时间,统计花费总时间。

解题思路:

纯模拟题。比较当前楼层与前一楼层的上下关系,然后统计上升的总楼层数以及下降的总楼层数,最后按照题意计算即可。

难度评测:Easy
AC代码实现:
#include <bits/stdc++.h>
using namespace std;
int a[105];

int main() {
	int n, up, down;
	cin >> n;
	up = down = 0;
	a[0] = 0;
	for(int i = 1; i <= n; i++) {
		cin >> a[i];
		if(a[i] > a[i - 1])
			up += a[i] - a[i - 1];
		else
			down += a[i - 1] - a[i];
	}
	int tot = up * 6 + down * 4 + 5 * n;
	cout << tot;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值