PAT甲级 1038 Recover the Smallest Number(30) (贪心)

这是一个关于数字组合的问题,给定一系列可能包含前导零的数字段,任务是组合这些段形成最小的数字。通过将所有数字转换为字符串并进行排序,然后贪心地连接它们,可以找到最小的组合。需要注意的是,最终结果中不能有前导零。
摘要由CSDN通过智能技术生成

题目

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

输入

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

输出

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

样例输入 

5 32 321 3214 0229 87

样例输出 

22932132143287

题意理解

给你n个数字 可能有前导0 让你拼一个最小的数 

我们可以贪心的考虑 将所有数字变成字符串处理

a和b的拼接 和 b和a拼接 哪个字典序更小 我们处理更小的那个将更小的拼接到前面

如果最后前面有前导0的话我们最后要处理干净前面的前导0

如果最后都是0的那么都被删除了话 直接输出一个0即可

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=1e5+10;
bool cmp(string a,string b){
    return a+b<b+a;
}
int main(){
    vector<string>ve;
    int n;
    cin>>n;
    string s;
    while(n--){
        cin>>s;
        ve.push_back(s);
    }
    sort(ve.begin(),ve.end(),cmp);
    string ans;
    for(auto tmp:ve){
        ans+=tmp;
    }
    while(ans.size()>0&&ans[0]=='0'){
        ans.erase(0,1);
    }
    if(ans.size()==0)cout<<"0"<<endl;
    else cout<<ans<<endl;
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值