PAT甲级:1038 Recover the Smallest Number

题目描述:

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

代码长度限制

16 KB

时间限制

200 ms

内存限制

64 MB

题目大意: 

题⽬⼤意:给⼀些字符串,求它们拼接起来构成最⼩数字的⽅式

解题思路: 

贪心

用 a + b < b + a 来判断a和b两个字符串的前后位置

Python3代码: 

import functools
lst = list(input().split())
N = int(lst[0]) ; lst = lst[1:]

def cmp(a,b) : # 自定义排序函数
    if a + b < b + a : return -1
    elif a + b == b + a : return 0
    else : return 1

lst.sort(key=functools.cmp_to_key(cmp))
ans = "".join(lst)
print(int(ans))

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

UCSD.KS

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值