PAT甲级 1041 Be Unique(20) (STL)

题目

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^{4}]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

输入

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^{5}) and then followed by N bets. The numbers are separated by a space.

输出

For each test case, print the winning number in a line. If there is no winner, print None instead.

样例输入 

样例输入1:

7 5 31 5 88 67 88 17
样例输入2:

5 888 666 666 888 888

样例输出 

样例输出1:

31
样例输出2:

None

题意理解

给你n个数字 输出第一个不重复的数字 没有就输出None 那么我们简单映射一下就可以了

这题直接用map或者unordered_map STL直接拿来用即可

代码 

#include <bits/stdc++.h>
using namespace std;
const int N=1e5+10;
int a[N];
map<int,int>ma;

int main(){
    int n;
    cin>>n;
    for(int i=1;i<=n;i++){
        cin>>a[i];
        ma[a[i]]++;
    }
    int res;
    int fl=0;
    for(int i=1;i<=n;i++){
        if(ma[a[i]]==1){
           res=a[i];
           fl=1;
           break;
         }
    }
    if(fl)cout<<res<<endl;
    else cout<<"None"<<endl;
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值