PAT甲级 1044 Shopping in Mars(25) (前缀和+双指针)

题目

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

输入

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10^{5}), the total number of diamonds on the chain, and M (≤10^{8}), the amount that the customer has to pay. Then the next line contains N positive numbers D_{1}D_{N} (D_{i}10^{3} for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

输出

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

样例输入 

样例输入1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
样例输入2:

5 13
2 4 5 7 9

样例输出 

样例输出1:

1-5
4-6
7-8
11-11
样例输出2:

2-4
4-5

题意理解

给你一个序列 然后让你输出在序列和里面等于m的子序列

如果找不到和等于m的子序列 那么就找在所有和大于m的子序列里面找一个和最小的子序列

那么我们采用前缀和维护区间和

然后双指针来找区间 

左指针不动 如果区间和小于m的话那么我就右指针不断向外面扩出去

如果扩到最后还是m那么直接break掉

将所有区间大于等于m的情况全部留下来

因为这里可能所有区间和都大于m 所以我们要在大于等于m的情况里

找到最小的那个

如果m的情况存在 那么最小的就是m 否则就要记录最小的数值

当扩到一个右边界时 左指针就要开始前进 找到在这里面大区间里面符合条件的区间序列

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=2e5+10;
const int INF=0x3f3f3f3f;
typedef pair<int,int> PII;
typedef long long LL;
#define fx first
#define fy second
vector<PII>ans;
int a[N],cha=INF;;
int sum[N];
int get(int l,int r){
    return sum[r]-sum[l-1];
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        sum[i]=sum[i-1]+a[i];
    }
    int l=1,r=1;
    while(l<=n){
       while(get(l,r)<m&&r<=n)r++;
       if(get(l,r)<m)break;
       else if(get(l,r)<cha){
           cha=get(l,r);
           ans.clear();
           ans.push_back({l,r});
       }
       else if(get(l,r)==cha){
           ans.push_back({l,r});
       }
       l++;
    }
    for(int i=0;i<ans.size();i++){
        printf("%d-%d\n",ans[i].fx,ans[i].fy);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值