BZOJ 1349: [Baltic2006]Squint 题解

1349: [Baltic2006]Squint

Time Limit: 1 Sec Memory Limit: 64 MB
Submit: 572 Solved: 338


Description

Write a program to calculate integer square roots.


Input

The input is read from a text file named squint.in. Its only line consists of an integer 0 < = n < 2^63 .


Output

Its only line consists of the smallest nonnegative integer q such that q^2 >= n .


Sample Input

122333444455555


Sample Output

11060446


HINT

sqrt(122333444455555)=11060445.038765619 .


Source


题解:

哇这种题还需要题解嘛

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
long long a,b;
int main(){
    scanf("%lld",&a);b=sqrt(a);
    if(b*b==a) printf("%lld",b);
    else       printf("%lld",b+1); 
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值