数据结构与算法 11_20

Red and Black

Tips: DFS;利用递归,对所走过的点进行标记,并判断边界。

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#
…
…
…
…
…
#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.
…
11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

Solution

# include<stdio.h>
#include<string.h>
#include<iostream>


int W,H;
int num;
char map[25][25];
int a[4];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
bool v[25][25];


void dfs(int x,int y)
{
	
	map[x][y]='#';	
	int p,q;
	for(int i=0;i<4;i++)
	{
		p=x+dx[i];
		q=y+dy[i];
		if(p>0&&q>0&&p<=W&&q<=H&&map[p][q]=='.')
		{	num++;
			v[p][q]=1;
			dfs(p,q);
			
		}
	}
	
	
}

int main(){
	int i,j;
	while((scanf("%d%d",&W,&H))!=EOF)
	{
	getchar();
	if(W==0&&H==0)
	{
		break;
	}
	memset(v,0,sizeof(v));
	int p1,q1;
	for(i=1;i<W;i++)
	{
		for(j=1;j<H;j++)
		{
		
		scanf("%c",&map[i][j]);
		if(map[i][j]=='@')
		{
			p1=i;
			q1=j;
			
		}
	}
	
	getchar();
	
	}
while(W!=0&&H!=0){
	int s=0;
	

	num=0;
	v[p1][q1]=1;
	dfs(p1,q1);
	a[s]=num;
	s++;
}
for(int s=0;s<4;s++)
{
	printf("%d\n",a[s]);
}
	
}

return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值