见微知著----POJ2259(队列)

POJ2259 Team Queue

Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.
Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:

  • ENQUEUE x - enter element x into the team queue
  • DEQUEUE - process the first element and remove it from the queue
  • STOP - end of test case

The input will be terminated by a value of 0 for t.
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.
Output
For each test case, first print a line saying “Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.
Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0
Sample Output
Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

问题简介:
在一个队列(team queue)中,每个元素(element)属于一个队伍(team)。
当输入命令为ENQUEUE时,元素入队列,若有同一队伍的队友已经在队列中,那么就将该元素排在该队友之后;若没有同一队伍的队友,则将其排在队列的最末位;
当输入命令为DEQUEUE时,元素以正常队列的方式出队列。
当输入命令为STOP时,退出程序。

问题解析:
这个问题如果只用一个队列来做的话,势必会很难完成。我们不妨设在一个队列中,有t只队伍(team)。我们用一个队列数组nQue来储存这t只队伍,并且用bool型数组nFlag来表示队列中是否存在各个队伍;同时我们用一个队列nS来储存出现的队伍的编号;而元素所在的队伍的编号,我们则用nM数组储存。
将输入的元素先存在nM数组里,从而我们获得了全体元素队伍的编号。
当输入命令为ENQUEUE时,检查其所对应的队伍是否有同组元素:
若没有,则将该队伍的编号入队伍nS,并将其nFlag值置为true,并将该元素入相应的nQue队列;
若有,直接入相应的nQue队列即可
当输入命令为DEQUEUE时,按照队列nS先处理先入队列的那批队伍,并将该队伍中元素逐一出队;若该队伍已经没有元素,将该队伍的nFlag值置为false,则队列nS中头元素出队列,并将nS新的头元素所在的队列开始出队。
这个题目的难点是用多个队伍队列和一个队号队列来表示一个完整的队列。

代码

#include <iostream>
#include <string>
#include <queue>
#include <map>
using namespace std;
int nCaseNum,nNum;  /*nNum是队的数量 */
queue<long> nQue[1001]; /* 存储每个队列*/
queue<int> nS;  /*存储队列号*/
int nM[1000000];    /*元素与队列的映射表 */
bool nFlag[1001]; /*标识有无同组元素*/

void init()
{
    for(int i=0; i!=nNum; i++)
    {
        nFlag[i] = false;
        while(!nQue[i].empty())
            nQue[i].pop();
    }
    while(!nS.empty())
        nS.pop();
}

void input()
{
    int nElem,elemNum;
    for(int i=0; i!=nNum; i++)
    {
        cin >> elemNum;     /*elemNum是单次输入元素的个数 ? */
        for(int j=0; j!=elemNum; j++)
        {
            cin >> nElem;
            nM[nElem] = i;  /*对应元素所在队列 i */
        }
    }

}

void solve()
{
    string Command;
    long nElem;
    cout<<"Scenario #" << ++nCaseNum << endl;
    while(cin >> Command,Command!="STOP")
    {
        if(Command == "ENQUEUE")
        {
            cin >> nElem;
            if(!nFlag[nM[nElem]])       /*是否有同组元素*/
            {
                nFlag[nM[nElem]] = true;
                nS.push(nM[nElem]); /*将组号入队列*/
            }
            nQue[nM[nElem]].push(nElem);
        }
        else if(Command == "DEQUEUE")
        {
            int id = nS.front();
            cout<<nQue[id].front()<<endl; 
            /*将nS的头元素所在的队列逐一出队列*/
            nQue[id].pop();
            if(nQue[id].empty())
            {
                nS.pop();
                nFlag[id] = false;
            }
        }

    }
      cout << endl;
}

int main()
{
    nCaseNum = 0;
    while(cin >> nNum,nNum)
    {
        init();
        input();
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值