poj3278-catch that cow(bfs广搜)

先贴题目
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 59759 Accepted: 18581
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source

USACO 2007 Open Silver

题意就是从一个数经过+1,-1, *2 如何用最小的操作次数达到另一个数。

找最短路径和最优解就是广搜没跑了。

#include<iostream>
#include<queue>
#include<cstring>
#define INF 10e7
const int M = 100001;
using namespace std;
int dir[3][2] = {{1,1}, {1,-1}, {2,0}};
struct POINT
{
    int pos,
        step;
}now, next;
queue<POINT> Q;
bool visit[M];
int N, K;
int bfs()
{
    while(!Q.empty())
        Q.pop();
    now.pos = N;
    now.step = 0;
    visit[now.pos] = true;
    Q.push(now);
    while(!Q.empty())
    {
        now = Q.front();
        Q.pop();
        next = now;
        for(int i = 0; i < 3; i ++)
        {
            next.pos = now.pos * dir[i][0] + dir[i][1];
            next.step = now.step + 1;
            if(next.pos < 0 || next.pos > M)
                continue;
            else if(next.pos == K)
                return next.step;
            else if(!visit[next.pos])
            {
                Q.push(next);
                visit[next.pos] = true;
            }
        }
    }
    return INF;
}

int main()
{
    while(cin >> N >> K)
    {
        memset(visit,false,sizeof(visit));
        if(N < K)
            cout << bfs() << endl;
        if(N == K)
            cout << 0 << endl;
        if(N > K)
            cout << N - K << endl;
    }
}

还是经典的写法, 不过这个函数没有用参数,大概是因为都使用了全局变量吧。刚学的时候写起来还是很难的,看都看不懂,多写几次就会好一点。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值