poj3984-迷宫问题(广搜)

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10736 Accepted: 6400
Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

//memory:224k time:0ms
#include<iostream>
#include<cstdio>
#include<queue>
#include<stack>
const int size = 5;
using namespace std;
int **maze;     //二维数组
struct point{
    int x,
        y;
};
point **pre;    //二维结构体
int row = size;
int col = size;
point move[4] = {{1,0},{0,1},{-1,0},{0,-1}};    //四个移动方向
void createmaze(int row, int col)   //用1把maze的四周包围起来,免去判断是否出界的麻烦
{
    for(int i = 0; i < col + 2; i ++)
    {
        maze[0][i] = maze[row + 1][i] = 1;
    }
    for(int j = 0; j < row + 2; j ++)
    {
        maze[j][0] = maze[j][col + 1] = 1;
    }
    for(int i = 1; i < row + 1; i ++)
        for(int j = 1; j < col + 1; j ++)
            cin >> maze[i][j];
}

void findpath(int row, int col, int x, int y)
{
    if(x == row && y == col)//找到终点
        return ;
    queue<point> q;         //队列用于记录储存点
    point now;
    now.x = x;
    now.y = y;
    q.push(now);            //当前点压栈
    maze[now.x][now.y] = -1;
    while(!q.empty())       //找不到出口q就为空了
    {
        now = q.front();    //读取队首点
        q.pop();            //队首点出列
        for(int i = 0; i < 4; i ++)
        {
            if(now.x + move[i].x == row && now.y + move[i].y == col)    //判断是否到达终点
            {
                pre[row][col] = now;    //记录路径
                maze[now.x + move[i].x][now.y+move[i].y] = -1;    //标记,不能再走
                return;
            }
            else if(maze[now.x + move[i].x][now.y+move[i].y] == 0 )    //判断是否有出口
            {
                point temp;    //临时点 记录下一个点的位置
                temp.x = now.x + move[i].x;
                temp.y = now.y + move[i].y;
                q.push(temp);    //把下一个点压栈 在循环开始处会成为当前点,这就是队列的作用,FIFO
                maze[temp.x][temp.y] = -1;
                pre[temp.x][temp.y] = now;
            }
        }
    }
}
void printpath()
{
    stack<point> q;    //定义栈,用于从终点开始存储路径
    point temp ;    //从终点开始
    temp.x = row;
    temp.y = col;
    while(temp.x != 1 || temp.y != 1)    //是否到达起点
        {
            q.push(temp);    
            temp = pre[temp.x][temp.y];    //temp不断前移
        }
    q.push(temp);    //最后一个点也要压入
    while(!q.empty())    //输出
    {
        temp = q.top();    //从栈顶开始输出,利用栈的特性从起点开始输出
        cout << "(" << temp.x - 1<< ", " << temp.y - 1 << ")" << endl;    //因为输入的时候从1开始,这里要减1.
        q.pop();    //用一个点出一个
    }
}
int main()
{
   //freopen("output.txt","r",stdin);
    maze = new int*[row + 2];
    pre = new point*[row + 2];
    for(int i = 0; i < row + 2; i ++)
    {
        maze[i] = new int[col + 2];
        pre[i] = new point[col + 2];
    }
    createmaze(row, col);

    findpath(row,col,1,1);
//    for(int i =1; i < row + 1; i ++)
//    {
//        for(int j = 1; j < col + 1; j ++)
//            cout << pre[i][j].x << "." << pre[i][j].y <<" ";
//        cout << endl;
//    }
    printpath();
    return 0;
}
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的索算法,找到从起点到终点的最短路径。可以使用广度优先索或者深度优先索算法来解决这个问题。 下面是一个使用广度优先索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先索算法,首先读入迷宫地图,然后从起点开始进行索,直到找到终点为止。在索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用来输出路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值