2016天梯赛 个位数统计

</pre>题干:<p></p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)">给定一个k位整数N = d<sub style="line-height:0">k-1</sub>*10<sup style="line-height:0">k-1</sup> + ... + d<sub style="line-height:0">1</sub>*10<sup style="line-height:0">1</sup> + d<sub style="line-height:0">0</sub> (0<=d<sub style="line-height:0">i</sub><=9, i=0,...,k-1, d<sub style="line-height:0">k-1</sub>>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定N = 100311,则有2个0,3个1,和1个3。</p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)"><strong>输入格式:</strong></p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)">每个输入包含1个测试用例,即一个不超过1000位的正整数N。</p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)"><strong>输出格式:</strong></p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)">对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M。要求按D的升序输出。</p><span style="color:rgb(51,51,51); font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; line-height:18px; background-color:rgb(250,250,250)">输入样例:</span><pre style="margin-top:1.5em; margin-bottom:1.5em; padding:0px; border:0px; line-height:18px; font-family:'Droid Sans Mono',Consolas,'Courier New',monospace; vertical-align:baseline; overflow:auto; color:rgb(51,51,51); background-color:rgb(250,250,250)">100311
输出样例:
0:2
1:3
3:1
水题,详见代码:
 

#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

char s[1005];
int a[10];

int main(){
	int i,l;
	while(cin>>s){
		l = strlen(s);
		memset(a,0,sizeof(a));
		for(i = 0;i < l;i++){
			a[s[i] - '0']++;
		}
		for(i = 0;i < 10;i++){
			if(a[i]!=0)
				printf("%d:%d\n",i,a[i]);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值