【PTA-A】1024 Palindromic Number(大整数)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

其他测试数据:

484 2
//output
484
0

思路:

1.输入字符串和循环次数

2.字符串转换成数字存储到数组a,逆序存储到数组b

3.循环,temp存储a+b的结果,从最后一位向前遍历,如果a+b≥10,保存余数,前一位进一

4.判断是否回文,是则输出当前a数组和已循环次数;否则更新a=temp,b等于a的逆序

5.如果达到循环次数后都没有出现回文,输出当前数字和循环次数

注意点: 

1.一次循环结束后更新需要相加的两个数字(即数组)。

2.当达到循环次数后退出循环

3.保存相加结果时要从后往前,记得进位

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int a[10001], b[10001], temp[10001] = { 0 };

int main() {
	string n;
	int k;
	cin >> n >> k;
	int len = n.length();
	for (int i = 0; i < len; i++) {
		a[i] = n[i] - '0';    //保存数字
		b[len - i - 1] = a[i];   //逆序
	}
	int j;
	for (j = 0; j < k; j++) {
		memset(temp, 0, sizeof(temp));
		for (int i = len; i > 0; i--) {   //更新两数组相加结果
			temp[i] += a[i - 1] + b[i - 1];
			if (temp[i] >= 10) {
				temp[i] %= 10;
				temp[i - 1]++;
			}
		}
		int flag = 1, i = 0;
		for (int i = 0; i < len/2; i++) {
			if (a[i] != a[len - i - 1]) {   //判断是否回文
				flag = 0;
				break;
			}
		}
		if (flag) {   //是则输出
			for (int i = 0; i < len; i++) {
				cout << a[i];
			}
			cout << endl << j ;
			break;
		}
		else {   //不是,更新ab数组,继续循环
			int cur = 0;
			for (int i = 0; i < len + 1; i++) {
				if (i == 0 && temp[i] == 0)continue;
				a[cur] = temp[i];
				b[cur]=temp[len-cur];
				cur++;
			}
			len = cur;
		}
	}
	if (j >= k) {   //循环结束没有出现回文
		for (int i = 0; i < len ; i++) {
			cout << a[i];
		}
		cout << endl << k;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值