【PAT甲级 - C++题解】1027 Colors in Mars

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1027 Colors in Mars (pintia.cn)
🔑中文翻译:火星颜色
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456
题意

给定三个十进制数,让我们将他们转换成十三进制(0~9,A~C)并输出,如果给定的十进制数转换成十三进制只有一位,那么在前面还需要补一个 0 ,例如十进制 10 转换成十三进制输出 0A

思路
  1. 用数组输入三个十进制数,方便后续处理。
  2. 将每个十进制数转换两位十三进制的数,第一位用十进制数除以 13 ,第二位则用十进制数余上 13
代码
#include<bits/stdc++.h>
using namespace std;

char get(int x)
{
    if (x >= 10)   return x - 10 + 'A';
    return x + '0';
}

int main()
{
    int a[3];
    for (int i = 0; i < 3; i++)    cin >> a[i];

    cout << "#";
    for (int i = 0; i < 3; i++)    cout << get(a[i] / 13) << get(a[i] % 13);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值