【PAT甲级 - C++题解】1031 Hello World for U

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1031 Hello World for U (pintia.cn)
🔑中文翻译:U 形 Hello World
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1031 Hello World for U

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1=n3=max { k | kn2 for all 3≤n2≤N } with n1+n2+n3−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor
题意

给定一个长度为 N 的字符串,请你将它以 U 形输出。

也就是说,必须按照原始顺序输出字符,左垂直线自上而下共有 n1 个字符,底部行从左到右共有 n2 个字符,右垂直线自下而上共有 n3 个字符。

另外,必须满足 n1=n3=max{k|k≤n2对于所有3≤n2≤N} 以及 n1+n2+n3−2=N

思路

由题可知:

  • n1+n2+n3-2=N
  • n1=n3
  • n1<=n2

所以可得:

n2=N-2*n1+2

再带入到 n1<=n2 可得:

n1<=N+2*n1+2n1<=(N+2)/3

n1=n3=(N+2)/3n2=n1+(N+2)%3

然后按照 U 字形顺序将字符串填入数组,最后输出数组即可。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 100;
char g[N][N];

int main()
{
    string str;
    cin >> str;
    //计算n1,n2,n3
    int n1 = (str.size() + 2) / 3;
    int n2 = n1 + (str.size() + 2) % 3;

    //将字符串按照U字形填入数组
    int k = 0;
    for (int i = 1; i <= n1; i++)      g[i][1] = str[k++];
    for (int i = 2; i <= n2; i++)      g[n1][i] = str[k++];
    for (int i = n1 - 1; i >= 1; i--)    g[i][n2] = str[k++];

    //输出填充后
    for (int i = 1; i <= n1; i++)
    {
        for (int j = 1; j <= n2; j++)
            if (g[i][j]) cout << g[i][j];
            else    cout << " ";
        cout << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值