【PAT甲级 - C++题解】1083 List Grades

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1083 List Grades (pintia.cn)
🔑中文翻译:成绩单
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1083 List Grades

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE
题意

给定一个成绩范围 [g1,g2] ,要求找出在该成绩范围内的学生,并输出相应信息。

思路

思路如下:

  1. 定义学生结构体,存储学生信息,并重载比较运算符,排序时按照成绩降序排序。
  2. 输入学生的信息以及规定的成绩范围。
  3. 从前往后数组,将在成绩范围内的学生放到数组前面。
  4. 如果没有学生在成绩范围内,则输出 NONE ;反之,对在成绩范围内的学生按照成绩降序排序并输出其 nameid
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 110;
int n;

//定义学生结构体
struct Person
{
    string name, id;
    int g;

    bool operator<(const Person& t)const
    {
        return g > t.g;
    }
}p[N];

int main()
{
    //输入学生信息
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> p[i].name >> p[i].id >> p[i].g;

    //给定成绩范围
    int g1, g2;
    cin >> g1 >> g2;

    //将在给定成绩范围内的学生找出来
    int m = 0;
    for (int i = 0; i < n; i++)
        if (p[i].g >= g1 && p[i].g <= g2)
            p[m++] = p[i];

    //打印结果
    if (!m)  puts("NONE");
    else
    {
        //按照成绩降序排序
        sort(p, p + m);
        for (int i = 0; i < m; i++)
            cout << p[i].name << " " << p[i].id << endl;
    }

    return 0;
}
  • 4
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值