✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1040 Longest Symmetric String (pintia.cn)
🔑中文翻译:最长回文子串
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪
1040 Longest Symmetric String
Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given
Is PAT&TAP symmetric?
, the longest symmetric sub-string iss PAT&TAP s
, hence you must output11
.Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.
Output Specification:
For each test case, simply print the maximum length in a line.
Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11
题意
需要我们求出给定字符串中回文子串的最长长度。
思路
这道题直接枚举即可,对字符串的每个字符都进行枚举:
- 先求子串长度为奇数的情况,长度为
r-l-1
。 - 再求子串长度为偶数的情况,长度同样为
r-l-1
。
最后输出得到的最长回文子串长度即可。
代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
//输入字符串
string s;
getline(cin, s);
//计算最长回文子串
int res = 0;
for (int i = 0; i < s.size(); i++)
{
//先枚举奇数结点的情况
int l = i - 1, r = i + 1;
while (l >= 0 && r < s.size() && s[l] == s[r]) l--, r++;
res = max(res, r - l - 1);
//再枚举偶数结点的情况
l = i, r = i + 1;
while (l >= 0 && r < s.size() && s[l] == s[r]) l--, r++;
res = max(res, r - l - 1);
}
//输出答案
cout << res << endl;
return 0;
}