1040 Longest Symmetric String

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:

11

#include<iostream>
#include<string>
using namespace std;
int main(){
	for(string str;getline(cin,str);){
		int max_length = 1;
		for(int i = 0; i < str.length();i++){
			int length1 = 1;
			int length2 = 1;
			//判断长度为偶数的情况
			int index_1 = i;
			int index_2 = i+1;
			if(index_1 < 0 || index_2 >= str.length()){
				continue;
			}
			if(str[index_1] == str[index_2]){
				length1 = 2;
				while(1){
					index_1--;
					index_2++;
					if(index_1 < 0  || index_2 >= str.length()){
						break;
					}
					if(str[index_1] == str[index_2]){
						length1+=2;
					}else{
						break;
					}
				}
			}
			//判断长度为奇数的情况
			index_1 = i-1;
			index_2 = i+1;
			if(index_1 < 0 || index_2 >= str.length()){
				continue;
			}
			if(str[index_1] == str[index_2]){
				length2 = 3;
				while(1){
					index_1--;
					index_2++;
					if(index_1 < 0 || index_2 >= str.length()){
						break;
					}
					if(str[index_1] == str[index_2]){
						length2+= 2;
					}else{
						break;
					}
				}
			}
			if(length1 > max_length){
				max_length = length1;
			}
			if(length2 > max_length){
				max_length = length2;
			}
		}
		cout<<max_length<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值