PAT甲级1040 Longest Symmetric String (25分)|C++实现

一、题目描述

原题链接
Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

​​Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

二、解题思路

这道题主要是要找出最大对称子串的大小,我的思路是这样的:遍历字符串中的所有字符,以这个字符为中心,向左右两边扩展,将所得字符串用reverse函数翻转,看是否与原来相同,但是要注意的是这里子串要分奇偶两种情况讨论,用ans存储当前对称子串的最大长度,进行更新即可。

三、AC代码

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
using namespace std;
bool check(string str, int i, int r, int isOdd)
{
    if(r == 0)  return true;
    if(isOdd == 0)
    {
        if(i+1-r<0) return false;
        string tmp1 = str.substr(i+1-r, r);
        string tmp2 = str.substr(i+1, r);
        reverse(tmp2.begin(), tmp2.end());
        if(tmp1 == tmp2)    return true;
        else    return false;
    }
    else if(isOdd == 1)
    {
        if(i-r < 0) return false;
        string tmp1 = str.substr(i-r, r);
        string tmp2 = str.substr(i+1, r);
        reverse(tmp2.begin(), tmp2.end());
        if(tmp1 == tmp2)    return true;
        else    return false;
    }
}
int main()
{
    int ans=0;
    string str;
    getline(cin, str);
    int sze = str.length();
    for(int i=0; i<sze; i++)
    {
        for(int r=0; r<=min(sze-i-1, i+1); r++)
        {
            if(check(str, i, r, 0) && 2*r > ans)    ans = r*2;
            if(check(str, i, r, 1) && 2*r + 1 > ans)    ans = r*2+1;
        }
    }
    printf("%d", ans);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值