1040. Longest Symmetric String

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

ac代码:
//start 20:20
#include<stdio.h>
#include<string.h>
int max=0;
/*void issym(char *a,int c,int b)
{
	int i,j,nmax=0;
	if(c>=b) return;
	if((b-c)%2==0)
	{
		for(i=(b-c)/2-1,j=(b-c)/2;i>=0&&j<b;i--,j++,nmax=nmax+2)
		{
			if(a[i]!=a[j])
				break;
		}
	
	}
	else
	{
		for(i=(b-c)/2-1,j=(b-c)/2+1,nmax=1;i>=0&&j<b;i--,j++,nmax=nmax+2)
			if(a[i]!=a[j])
				break;
	}
   if(nmax>max) max=nmax;
   issym(a,c,(b-c)/2-1);
   issym(a,(b-c)/2,b);
}
*/

int main()
{
//	freopen("data.in","r",stdin);
	int i,j,k,n,m;
	char a[1010];
	gets(a);
//	issym(a,0,strlen(a));
	for(i=0;i<strlen(a);i++)

	{
		for(j=0;i-j>=0,i+j<strlen(a);j++)
		{
			if(a[i-j]!=a[i+j]) break;
			if(j*2+1>max)
			{
				max=j*2+1;
			}
			
		}
		for(j=0;i-j>=0,i+j+1<strlen(a);j++)
		{
			if(a[i-j]!=a[i+j+1]) break;
			if(j*2+2>max) max=j*2+2;
		}
	}
	 
	printf("%d\n",max);
	return 0;
}

 


转载于:https://www.cnblogs.com/scjyldq/archive/2012/10/03/2711094.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值