S - Counterfeit Dollar

S - Counterfeit Dollar

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings. 
Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even. 
Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined. 
Sample Input
1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 
Sample Output
K is the counterfeit coin and it is light. 

该题思路很简单,设定一个数组作为判断状态,一旦出现even,则每一个字母都是正确的重量,出现up时,只需将未设定为正确状态的位数做个标志,然后一次遍历输出即可;

代码如下:

//
//  main.cpp
//  S - Counterfeit Dollar
//
//  Created by 徐智豪 on 2017/3/26.
//  Copyright © 2017年 徐智豪. All rights reserved.
//
#include <iostream>
#include <string>
using namespace std;
int main(int argc, const char * argv[]) {
    int time;
    cin>>time;
    while(time--)
    {
        unsigned long int a[13]={ 1 } ;
        string s1,s2,answer;
        int n=3;
        while(n--)
        {
            cin>>s1>>s2>>answer;
            if(answer=="even")
            {
                for(auto t:s1)
                {
                    int temp=t-'A';
                    a[temp]=1;
                }
                for(auto t:s2)
                {
                    int temp=t-'A';
                    a[temp]=1;
                }
            }
            else if(answer=="up")
            {
                for(auto t2:s1)
                {
                    int temp=t2 - 'A';
                    if(a[temp]==0)
                        a[temp]=2;
                }
                for(auto t2:s2)
                {
                    int temp=t2 - 'A';
                    if(a[temp]==0)
                        a[temp]=2;
                }
            }
        }
        for(int i=0;i<12;i++)
        {
            if(a[i]==2)
            {
                char letter=i+'A';
                cout<<letter<<" is the counterfeit coin and it is light."<<endl;
                break;
            }
        }
    }
    
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值