ZOJ Problem Set - 3706 Break Standard Weight(暴力)

ZOJ Problem Set - 3706

Break Standard Weight

            Time Limit:  2 Seconds                                    Memory Limit:  65536 KB                            

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term “scales” for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.
Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100
Output

For each test case, output the maximum number of possible special masses.
Sample Input

2
4 9
10 10

Sample Output

13
9
题目大意:一共有两个数,问,把其中一个数拆成两个整数,得到两个新的数再加上未拆的数共三个数,加减组合能得到最多的不同的数有多少?方法:看到题目第一眼就想到暴力。。用a,b,c三个数去代替代码会简洁很多,还要注意就是0的时候不能算,因为题目意思是砝码称重,0当然不算。。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cctype>
#include<cstdio>
#include<cmath>
#include<map>
#include<set>
#include<queue>
#include<vector>//集合    __gcd(a,b)求最大公约数
#include<iomanip>//保留小数//cout<<fixed<<setprecision(6)<<a;//std::ios::sync_with_stdio(false);
#define eps 1e-7
using namespace std;
int main(void)
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        set<int>set;
        int x,y,maxn=1;
        scanf("%d%d",&x,&y);
        for(int i=1;i<=x/2;++i)
        {
            int a=i,b=x-i,c=y;
            set.insert(a);
            set.insert(b);
            set.insert(c);
            set.insert(a+b);
            if(abs(a-b)!=0)set.insert(abs(a-b));
            set.insert(a+c);
            if(abs(a-c)!=0)set.insert(abs(a-c));
            set.insert(b+c);
            if(abs(b-c)!=0)set.insert(abs(b-c));
            set.insert(a+b+c);
            if(abs(a+b-c)!=0)set.insert(abs(a+b-c));
            if(abs(a-b+c)!=0)set.insert(abs(a-b+c));
            if(abs(a-b-c)!=0)set.insert(abs(a-b-c));
            if(set.size()>maxn)maxn=set.size();
            set.clear();
        }
        for(int i=1;i<=y/2;++i)
        {
            int a=i,b=y-i,c=x;
            set.insert(a);
            set.insert(b);
            set.insert(c);
            set.insert(a+b);
            if(abs(a-b)!=0)set.insert(abs(a-b));
            set.insert(a+c);
            if(abs(a-c)!=0)set.insert(abs(a-c));
            set.insert(b+c);
            if(abs(b-c)!=0)set.insert(abs(b-c));
            set.insert(a+b+c);
            if(abs(a+b-c)!=0)set.insert(abs(a+b-c));
            if(abs(a-b+c)!=0)set.insert(abs(a-b+c));
            if(abs(a-b-c)!=0)set.insert(abs(a-b-c));
            if(set.size()>maxn)maxn=set.size();
            set.clear();
        }
        printf("%d\n",maxn);
    }
    return 0;
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值