变量重复定义

地址:http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=4998

Break Standard Weight

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and5, we can measure the object with mass 145 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ xy ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input
2
4 9
10 10
Sample Output
13
9


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int ads(int i)
{
	if(i<0) i*=-1;
	return i;
}
int main()
{
	int t,m,n,i,j,a[205],max,sum;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&m,&n);max=0;
		for(i=1;i<=m/2;i++)
		{
			memset(a,0,sizeof(a));sum=0;j=m-i;
			a[i]=1;
			a[j]=1;
			a[n]=1;
			a[i+j]=1;
			a[i+n]=1;
			a[j+n]=1;
			a[i+j+n]=1;
			a[ads(i-j)]=1;
			a[ads(n-j)]=1;
			a[ads(i-n)]=1;
			a[ads(i+n-j)]=1;
			a[ads(i+j-n)]=1;
			a[ads(j+n-i)]=1;
			for(j=1;j<=m+n;j++)
				if(a[j]==1) sum++;
			if(sum>max) max=sum;
		}
		if(m!=n)
		{
			for(i=1;i<=n/2;i++)
			{
				memset(a,0,sizeof(a));sum=0;j=n-i;
				a[i]=1;
				a[j]=1;
				a[m]=1;
				a[i+j]=1;
				a[i+m]=1;
				a[j+m]=1;
				a[i+j+m]=1;
				a[ads(i-j)]=1;
				a[ads(m-j)]=1;
				a[ads(i-m)]=1;
				a[ads(i+m-j)]=1;
				a[ads(i+j-m)]=1;
				a[ads(j+m-i)]=1;
				for(j=1;j<=m+n;j++)
					if(a[j]==1) sum++;
				if(sum>max) max=sum;
			}
		}
		printf("%d\n",max);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生参加学科竞赛有着诸多好处,不仅有助于个人综合素质的提升,还能为未来职业发展奠定良好基础。以下是一些分析: 首先,学科竞赛是提高专业知识和技能水平的有效途径。通过参与竞赛,学生不仅能够深入学习相关专业知识,还能够接触到最新的科研成果和技术发展趋势。这有助于拓展学生的学科视野,使其对专业领域有更深刻的理解。在竞赛过程中,学生通常需要解决实际问题,这锻炼了他们独立思考和解决问题的能力。 其次,学科竞赛培养了学生的团队合作精神。许多竞赛项目需要团队协作来完成,这促使学生学会有效地与他人合作、协调分工。在团队合作中,学生们能够学到如何有效沟通、共同制定目标和分工合作,这对于日后进入职场具有重要意义。 此外,学科竞赛是提高学生综合能力的一种途径。竞赛项目通常会涉及到理论知识、实际操作和创新思维等多个方面,要求参赛者具备全面的素质。在竞赛过程中,学生不仅需要展现自己的专业知识,还需要具备创新意识和解决问题的能力。这种全面的综合能力培养对于未来从事各类职业都具有积极作用。 此外,学科竞赛可以为学生提供展示自我、树立信心的机会。通过比赛的舞台,学生有机会展现自己在专业领域的优势,得到他人的认可和赞誉。这对于培养学生的自信心和自我价值感非常重要,有助于他们更加积极主动地投入学习和未来的职业生涯。 最后,学科竞赛对于个人职业发展具有积极的助推作用。在竞赛中脱颖而出的学生通常能够引起企业、研究机构等用人单位的关注。获得竞赛奖项不仅可以作为个人履历的亮点,还可以为进入理想的工作岗位提供有力的支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值