树2 List Leaves(Java)

题目

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
4 1 5

解答

树2的题解法与树1类似,主要考察建树和对树进行层序遍历。在本题中只要建完树并找到根节点后,对根节点进行层序遍历,即可从上到下,从左到右找到叶节点的索引。

import java.io.*;
import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        ArrayList<Node> nodes = bufferedRead(br);
        br.close();
        Node root = buildTree(nodes);
        if (root == null) {
            System.out.println("建树有错误");
            return;
        }
        ArrayList<Integer> indices = getIndex(root);
        for (int i = 0; i < indices.size(); i++) {
            System.out.print(indices.get(i));
            if (i != indices.size() - 1) {
                System.out.print(" ");
            }
        }
    }

    static ArrayList<Integer> getIndex(Node root) {
        ArrayList<Integer> indices = new ArrayList<>();
        Queue<Node> queue = new LinkedList<>();
        queue.add(root);
        while (!queue.isEmpty()) {
            Node node = queue.remove();
            if (node.left != null) {
                queue.add(node.left);
            }
            if (node.right != null) {
                queue.add(node.right);
            }
            if (node.left == null && node.right == null) {
                indices.add(node.index);
            }
        }
        return indices;
    }
    static Node buildTree(ArrayList<Node> nodes) {
        int[] index = new int[nodes.size()];
        for (int i = 0; i < nodes.size(); i++) {
            index[i] = i;
        }
        for (int i = 0; i < nodes.size(); i++) {
            if (nodes.get(i).leftNo != -1) {
                nodes.get(i).left = nodes.get(nodes.get(i).leftNo);
                index[nodes.get(i).leftNo] = -1;
            }
            if (nodes.get(i).rightNo != -1) {
                nodes.get(i).right = nodes.get(nodes.get(i).rightNo);
                index[nodes.get(i).rightNo] = -1;
            }
        }
        for (int i = 0; i < nodes.size(); i++) {
            if (index[i] != -1) {
                return nodes.get(i);
            }
        }
        return null;
    }
    static ArrayList<Node> bufferedRead(BufferedReader br) throws IOException{
        int num = Integer.parseInt(br.readLine());
        ArrayList<Node> nodes = new ArrayList<>(num);
        for (int i = 0; i < num; i++) {
            int leftNo, rightNo;
            String str = br.readLine();
            String[] strArr = str.split(" ");
            if (!strArr[0].equals("-")) {
                leftNo = Integer.parseInt(strArr[0]);
            } else {
                leftNo = -1;
            }
            if (!strArr[1].equals("-")) {
                rightNo = Integer.parseInt(strArr[1]);
            } else {
                rightNo = -1;
            }
            nodes.add(new Node(i, leftNo, rightNo));
        }
        return nodes;
    }
    static class Node {
        public int leftNo;
        public int rightNo;
        public Node left;
        public Node right;
        public int index;

        public Node(int index, int leftNo, int rightNo) {
            this.index = index;
            this.leftNo = leftNo;
            this.rightNo = rightNo;
            left = null;
            right = null;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值