ACboy needs your help 分组背包

 

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6
 


题意是有N天要学M门课,A[i][j]表示第i门课花了j天获得的价值,求如何选择使得获得的价值是最大的。

 

代码如下:

/*
分组背包  其二维形式是f[i][j]表示前i组放在容量为v中所获得的最大价值
其一维状态转移方程为f[v]=max{f[v],f[v-c[i]]+w[i]},其中c[i]为每组中某件物品的体积,
w[i]为相应的价值
不太理解的朋友可看背包九讲之可分组的背包问题
*/
#include<iostream>
using namespace std;
int a[105][105];
int dp[105];
int N,V;
void bag()
{
    int i,j,k;
    for(i=1;i<=N;i++)//组数
    {
        for(j=V;j>=0;j--)//背包的体积
        {
            for(k=1;k<=V;k++)//每组的体积
            {
                if(j>=k)//想想就理解了
                    if(dp[j]<dp[j-k]+a[i][k])
                        dp[j]=dp[j-k]+a[i][k];
            }
        }
    }
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&N,&V),N+V)
    {
        memset(dp,0,sizeof(dp));//初始化
        for(i=1;i<=N;i++)
        {
            for(j=1;j<=V;j++)
                scanf("%d",&a[i][j]);
        }
        bag();
        printf("%d\n",dp[V]);
    }
    return 0;
}


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值