ZOJ 1489-2^x mod n = 1-费马小定理+暴力枚举

Give a number n, find the minimum x that satisfies 2x mod n = 1.

Input

One positive integer on each line, the value of n.

Output

If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input

2
5

Sample Output

2^? mod 2 = 1
2^4 mod 5 = 1

题目大意:

给定n,寻找满足2x mod n = 1的最小正整数x。

核心思想:

如果n是偶数,即2x和n都是2的倍数,那么取模不可能得到1。
如果n是奇数,根据费马小定理:
若a和p互素,则ap-1 mod p = 1。
答案一定存在,且0<x<=n-1。
从1开始暴力枚举,余数为1就break。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
	ll n;
	while(scanf("%lld",&n)!=EOF)
	{
		if(n==1||n%2==0)
		{
			printf("2^? mod %lld = 1\n",n);
			continue;
		}
		ll t=1,i=0;
		for(i=1;;i++)
		{
			t=(t*2)%n;
			if(t==1)
				break;
		}
		printf("2^%lld mod %lld = 1\n",i,n);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值