POj1862 求一组数据中经过某个运算后的最小值

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

------------------------------------------

解题思路:题目给出一个公式   2乘以m1*m2的根号, 可以通过公式知道,当一组数组中,按最大数两两结合,则一定能得到这组数据的最小值,可以举一些数字去理解。所以可以给数组排序,从大小或从小到大。下面我给出两组程序,第一个为小到大,采用的是冒泡排序,第二种采用的是调用库函数。若采用从小到大,我们的值可以在两者大数合并了之后存到下标小的那个位置,继续进行合并,采用从大到小,反过来用就可以了。我主要是想记录库函数的调用。

 #include<iostream>
#include<math.h>
#include<stdio.h>
using namespace std;
#define max  100
int main()
{
double a[max];
int  n;
cin >> n;
int i,j;
double temp=0;
for (i = 0; i < n; i++)
{
cin >>a[i]  ;
}
for (i = 0; i < n - 1; i++)
{
for (j = i + 1; j < n; j++)
{
if (a[i] > a[j])
{
temp = a[i];
a[i] = a[j];
a[j] = temp;
}
}
}
for(i=n-1;i>0;i--)
{
a[i-1] = 2 * sqrt(a[i ] * a[i-1]);
}
printf("%.3lf\n",a[0]);
return 0;
--------------------------------------
 #include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define max  100
int cmp(double a, double b)  //比较的函数,返回大的值
{
return a > b;
}
int main()
{
int n;               //表示该组数据共有多少个元素
int  i;
double a[max];   //定义数组
while (cin>>n)
{
for (i = 0; i < n; i++)
{
cin >> a[i];   //输入数组的值
}
sort(a, a + n, cmp);  //调用排序使数组中的值由大到小,一定注意要用库函数,第一个参数为数组首地址,第二个参数为数组的长度,第三个表示比较的函数
for (i = 0; i < n; i++)
{
a[i + 1] = 2 * sqrt(a[i]*a[i+1]); 求出两两合并的值
}
printf("%.3lf",a[n-1]);
}
return 0;





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值