#POJ1862#Stripies(贪心 + 数学分析)

15 篇文章 0 订阅

Stripies
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17240 Accepted: 7807

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

题意:

给出n 个物体,分别给出每个的质量,并且两个物体(假设质量分别为m1,m2)相撞的时候变成一个物体,

质量为2*sqrt(m1*m2),并且只会出现两个两个物品碰撞的情况,问最终能得到的物体的最小质量是多少。


设质量为a, b, c,令a > b > c >

则有:

Ans = sqrt(sqrt(2 * a * b) * c * 2) or

Ans = sqrt(2 * a * sqrt(2 * b * c)) 

可见在一式中最大数a被两次开根,而二式中只一次开根,

那么一式要比二式更优,于是每次选择最大的两个数开根计算,让大数尽量多被开根

答案最小


Code:

Status Accepted
Time 32ms
Memory 192kB
Length 506
Lang C++
Submitted
Shared

#include<iostream> 
#include<cstdio> 
#include<cstdlib> 
#include<cmath> 
#include<algorithm> 
#include<vector> 
#include<queue> 
#include<cstring> 
using namespace std; 

int N;
priority_queue<double>Q;

int main(){
	while(~scanf("%d", &N)){
		double x;
		for(int i = 0; i < N; ++ i)
			scanf("%lf", &x), Q.push(x);
		while(Q.size() > 1){
			double a = Q.top();	Q.pop();
			double b = Q.top();	Q.pop();
			x = 2 * sqrt(a * b);
			Q.push(x);
		}
		printf("%.3lf\n", Q.top());
		Q.pop();
	}
    return 0; 
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值