RGCDQ
Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know
maxGCD(F(i),F(j))
(L≤i<j≤R)
Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.
All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
In the next T lines, each line contains L, R which is mentioned above.
All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
Output
For each query,output the answer in a single line.
See the sample for more details.
See the sample for more details.
Sample Input
2 2 3 3 5
Sample Output
1 1
题目大意:每个数的质因子种类数为i(j),求出在[l,r]区间内 max(i,j)
思 路: 模拟
刚开始想要根据求素数的函数求出每个数的质因子种类数目,但是后来发现这样的错的大部分结果相同,但是仍有部分是错误的。
同时 ,注意7个数目的特判,否则会超时。
代码如下:
/*踏实!!努力!!*/
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
using namespace std;
#define M 1000010
int L,R;
int prime[M],num[10],f[M],yes[1010],cnt;
int seven[10]={510510,570570,690690,746130,870870,881790,903210,930930};
void Prime()
{
memset(prime,0,sizeof(prime));
cnt=0;
for(int i=2; i<=M; i++)
if(!prime[i])
{
int j=i+i;
while(j<=M)
{
prime[j]=1;
j+=i;
}
}
for(int i=2; i<=1000; i++)
if(!prime[i])
yes[cnt++]=i;
f[1]=0;
for(int i=2; i<=M; i++)
{
int temp=i,ans=0;
for(int j=0; j<cnt; j++)
{
if(temp==1)
break;
if(!prime[temp])
{
ans++;
break;
}
if(temp%yes[j]==0)
{
ans++;
while(temp%yes[j]==0)
temp/=yes[j];
}
}
f[i]=ans;
}
return ;
}
int main()
{
int T;
Prime();
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&L,&R);
memset(num,0,sizeof(num));
int ans=0;
for(int i=0; i<8; i++)
if(L<=seven[i]&&seven[i]<=R)
ans++;
if(ans>=2)
{
printf("7\n");
continue;
}
for(int i=R; i>=L; i--)
{
num[f[i]]++;
if(num[6]>=2)
break;
}
int i;
for(i=6; i>=2; i--)
if(num[i]>=2)
break;
if(i>=2)
{
printf("%d\n",i);
continue;
}
ans=0;
if(num[2]==1) ans++;
if(num[4]==1) ans++;
if(num[6]==1) ans++;
if(ans>=2)
printf("2\n");
else
printf("1\n");
}
return 0;
}