POJ3468 A Simple Problem with Integers(树状数组区间修改+区间查询)

传送门

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

这道题是区间修改加区间查询,可以用树状数组,也可以用线段树来做
关键的部分就是要用差分的思想,然后累加求和

AC代码如下

#include<iostream>
#include<algorithm>
#include<cstring> 
#include<string>
#define int long long
typedef long long ll;
const int MANX=1e5+10;
using namespace std;
int a[MANX],sum1[MANX],sum2[MANX],n,m; 
inline int lowbit(int x){
	return x&(-x);
}
inline void update(int i,int k){
	int x=i;
	while(i<=n){
		sum1[i]+=k;
		sum2[i]+=(x-1)*k;
		i+=lowbit(i);
	}
}
inline int getsum(int i){
	int ans=0,x=i;
	while(i>0){
		ans+=x*sum1[i]-sum2[i];
		i-=lowbit(i);
	}
	return ans;
}
signed main()
{
	ios::sync_with_stdio(false);    
	cin.tie(0);
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		cin>>a[i];
		update(i,a[i]-a[i-1]) ;
	} 
	string s;
	while(m--){
		cin>>s;
		if(s=="Q"){
			int x,y;
			cin>>x>>y;
			cout<<getsum(y)-getsum(x-1)<<endl;
		}
		else if(s=="C"){
			int x,y,z;
			cin>>x>>y>>z;
			update(x,z);
			update(y+1,-z);
		}
	}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值