POJ 2001 Shortest Prefixes

Language:
Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16792 Accepted: 7288

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source



【题目分析】

    一看题目,是很简单的字典树的题目。只要建立一棵字典树,然后记录一下节点的经过此数,如果唯一就找到了最短的前缀。如果没有最小前缀,就需要输出整个字符串了。

#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
	int now;
	int v;
};
int trie[50001][26];
node pos[50001];//每一个节点的信息 别问我为什么要记录当前节点的内容 其实可以删 但是我有空间任性 
string sl[5001],s;
int t=0;
int root=1;//这个变量就是搞笑的 
int sum=1;//总共的节点数 
void insert(string s)//插入字符串 字典树构建过程 
{
	int pp=1;
	pos[1].v++;
	for (int i=0;i<s.size();++i){
		if (trie[pp][s[i]-'a']!=0){
			pp=trie[pp][s[i]-'a'];
			pos[pp].v++;
		}
		else if (trie[pp][s[i]-'a']==0){
			trie[pp][s[i]-'a']=++sum;
			pos[sum].now=s[i]-'a';
			pos[sum].v++;
			pp=sum;
		}
	}
}
void find(string s)
{
	for (int i=0;i<s.size();++i) printf("%c",s[i]);
	printf(" ");
	int pp=1;
	for (int i=0;i<s.size();++i){
		printf("%c",s[i]);
		if (pos[trie[pp][s[i]-'a']].v==1){
			break;
		}
		pp=trie[pp][s[i]-'a'];
	}
	printf("\n");
}
int main()
{
	while(cin>>s){
		sl[++t]=s;
		insert(s); 
	}
	for (int i=1;i<=t;++i){
		find(sl[i]);
	}
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值