hdu6092 Rikka with Subset(母函数+思维)

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1445    Accepted Submission(s): 726


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has  n  positive  A1An  and their sum is  m . Then for each subset  S  of  A , Yuta calculates the sum of  S

Now, Yuta has got  2n  numbers between  [0,m] . For each  i[0,m] , he counts the number of  i s he got as  Bi .

Yuta shows Rikka the array  Bi  and he wants Rikka to restore  A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t70) , the number of the testcases. 

For each testcase, the first line contains two numbers  n,m(1n50,1m104) .

The second line contains  m+1  numbers  B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with  n  numbers  A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
  
  
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$
 

Source

 
题目大意:有一正数数组a[n],数组中任意多个(0~n)元素的和(相当于子集但允许大小相等的元素)为k的个数为b[k]个,根据b数组求a[n]数组。
解题思路:经过观察,不难发现数组b中b[0]=b[0]-1后序号最小的非零数就是数组a中最小值的个数,最小值为下标。根据这个结果我们就可以想到,我们可以求出已知数组a部分元素的所有子集(可以包含相等的值)的和为k的个数b'[k],找出b[i]-b'[i]中序号最小的非零元素就能找到数组a中未知元素中最小的元素及其个数,这样就可以依次求出数组a了。求数组b'时利用母函数,每次加上找到的新元素求出新的数组b'。
代码如下:
#include<bits/stdc++.h>
using namespace std;
long long a[55],b[10005],tmp1[10005],tmp2[10005];
void init(int m)
{
	tmp1[0]=1;
	for(int i=1;i<=m;i++)
	{
		tmp1[i]=0;
	}
}
void mf(int p,int m,int p0)
{
	int i,j;
	for(i=p0;i<p;i++)
	{
		for(j=m;j>=a[i];j--)
		{
			tmp1[j]+=tmp1[j-a[i]];
		}
	}
}
int f(int p,int m)
{
	int i;
	for(i=0;i<=m;i++)
	{
		tmp2[i]=b[i]-tmp1[i];
	}
	for(i=0;i<=m;i++)
	{
		if(tmp2[i]!=0)
			break;
	}
	while(tmp2[i]--)
	{
		a[p++]=i;
	}
	return p;
}
int main()
{
	std::ios::sync_with_stdio(false);
	int T,n,m;
	int p0,p,i;
	cin>>T;
	while(T--)
	{
		cin>>n>>m;
		for(i=0;i<=m;i++)
		{
			cin>>b[i];
		}
		p=0;
		p0=0;
		init(m);
		while(p<n)
		{
			mf(p,m,p0);
			p0=p;
			p=f(p,m);
		}
		cout<<a[0];
		for(i=1;i<n;i++)
		{
			cout<<' '<<a[i];
		}
		cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值