poj 1703 Find them, Catch them(带偏移量并查集)

poj 1703 Find them, Catch them(带偏移量并查集)
Time Limit: 1000ms Memory Limit: 65536kB

Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
    Input
    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
    Output
    For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source
POJ Monthly–2004.07.18


本题是带偏移量的并查集,和食物链类似不过比食物链简单。
一定要注意定义的偏移量是相对直接父结点的,如果写的时候搞不清楚怕搞错要用中间变量记下来。
这种题目一定要细心调试,注意细节,比如我犯过一个超级低级的错误是把单词拼错。


Accepted    7040kB  197ms   1040 B  G++
#include<stdio.h>
#include<memory.h>

const int MAX_N=100000;

int n,m;
int root[MAX_N+1];
bool diff[MAX_N+1];

int find(int x)
{
    if (root[x]==0)
        return x;
    else
    {
        int f=root[x];
        int r=find(f);
        root[x]=r;
        diff[x]^=diff[f];
        return r;
    }
}

void show()
{
    for (int i=1;i<=n;i++)
        printf("(%d)%d<%d>  ",i,root[i],diff[i]);
    printf("\n");
    return;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int cases,x,y,rx,ry;
    char cmd;
    scanf("%d",&cases);
    while (cases--)
    {
        scanf("%d%d\n",&n,&m);
        memset(root,0,sizeof(root));
        memset(diff,false,sizeof(diff));
        while (m--)
        {
            scanf("%c%d%d\n",&cmd,&x,&y);
            if (cmd=='D')
            {
                rx=find(x);
                ry=find(y);
                if (rx==ry)
                    continue;
                root[rx]=ry;
                diff[rx]=true^diff[x]^diff[y];
            }
            else
            {
                rx=find(x);
                ry=find(y); 
                if ((rx==ry) || (n==2))
                {
                    if ((diff[x]^diff[y]) && (n!=2))
                        printf("In different gangs.\n");
                    else
                        printf("In the same gang.\n");
                }
                else
                    printf("Not sure yet.\n");
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值