poj 1442 Black Box(Treap)

poj 1442 Black Box(Treap)
Time Limit: 1000ms Memory Limit: 65536kB
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions).

There are two types of transactions:
ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in

the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.
Let us examine a possible sequence of 11 transactions:

Example 1
N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)

操作序号操作iboxGET
1ADD(3)03
2GET133
3ADD(1)11, 3
4GET21, 33
5ADD(-4)2-4, 1, 3
6ADD(2)2-4, 1, 2, 3
7ADD(8)2-4, 1, 2, 3, 8
8ADD(-1000)2-1000, -4, 1, 2, 3, 8
9GET3-1000, -4, 1, 2, 3, 81
10GET4-1000, -4, 1, 2, 3, 82
11ADD(2)4-1000, -4, 1, 2, 2, 3, 8

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:
1. A(1), A(2), …, A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
2. u(1), u(2), …, u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, … and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), …, u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), …, A(u(p)) sequence.

Input
Input contains (in given order): M, N, A(1), A(2), …, A(M), u(1), u(2), …, u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source
Northeastern Europe 1996


本题是Treap模板题目,外加需要维护左子树结点个数。具体见代码,细节要写熟练,不要写错。


Accepted    2772kB  73ms    1908 B  G++
#include<stdio.h>

const int MAX_M=30000;
typedef int array_type[MAX_M+1];

int data[MAX_M];
array_type l,r,f,ln,v,p;
int len=1;

int random();
int get(int head,int k);
void insert(int head,int node);

int main()
{
    //freopen("input.txt","r",stdin); 
    int m,n,x,last=-1;
    l[0]=r[0]=f[0]=-1;
    ln[0]=0;
    v[0]=p[0]=0x80000000;
    scanf("%d%d",&m,&n);
    for (int i=0;i<m;i++)
        scanf("%d",&data[i]);
    for (int i=0;i<n;i++)
    {
        scanf("%d",&x);
        for (int j=last+1;j<=x-1;j++)
        {
            l[len]=r[len]=f[len]=-1;
            v[len]=data[j];
            ln[len]=0;
            p[len]=random();
            insert(0,len);
            len++;
        }
        last=x-1;
        /*
        for (int t=0;t<=x;t++)
            printf("(f,l,r)=(%d,%d,%d) v=%d p=%d ln=%d\n",
                f[t],l[t],r[t],v[t],p[t],ln[t]);
        */
        printf("%d\n",get(0,(i+1)+1));
    }
    return 0;
}

void rotate_left(int head)
{
    int L=l[head],R=r[head],F=f[head];
    r[head]=l[R];f[l[R]]=head;
    f[head]=R;l[R]=head;
    f[R]=F;if (l[F]==head) l[F]=R; else r[F]=R;
    ln[R]+=ln[head]+1;
    return; 
}
/*      F
 *    head
 *  L      R
 */

void rotate_right(int head)
{
    int L=l[head],R=r[head],F=f[head];
    l[head]=r[L];f[r[L]]=head;
    f[head]=L;r[L]=head;
    f[L]=F;if (l[F]==head) l[F]=L; else r[F]=L;
    ln[head]-=ln[L]+1;
    return;
}
/*      F
 *    head
 *  L      R
 */

void insert(int head,int node)
{
    if (v[node]<=v[head])
    {
        if (l[head]==-1)
        {
            ln[head]++;
            l[head]=node;
            f[node]=head;
        }
        else
        {
            insert(l[head],node);
            ln[head]++;
        }
        if (p[l[head]]<p[head])
            rotate_right(head);
    }
    else
    {
        if (r[head]==-1)
        {
            r[head]=node;
            f[node]=head;
        }
        else
            insert(r[head],node);
        if (p[r[head]]<p[head])
            rotate_left(head);
    }
    return;
}

int get(int head,int k)
{
    //printf("get(%d,%d)\n",head,k);
    if (ln[head]==k-1)
        return v[head];
    else if (ln[head]<k-1)
        return get(r[head],k-1-ln[head]);
    else
        return get(l[head],k);
}

int random()
{
    static int x=1234567;
    x=(x*1003+13)%1000000009;
    return x;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值