POJ 2492 A Bug's Life(虫虫危机)

[poj 2492] (http://poj.org/problem?id=2492)
题目描述:
A Bug’s Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 31193 Accepted: 10221
Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual(个别的) bugs and their interactions(相互交流) were easy to identify(判别身份), because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual(同性恋的) bugs or if it contains some bug interactions that falsify(伪造,撒谎) it.
Input

The first line of the input contains the number of scenarios(方案). Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively(连续的) starting from one.
Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious(可疑的) bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption(假定) is definitely(确定的) wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint

Huge input,scanf is recommended.

#include <iostream>
#include <stdio.h>
using namespace std;
int father[2005];
int relation[2005];

int find_father(int i)
{
    int t;
    if(father[i]==i)
    {
        return i;
    }
    t=father[i];
    father[i]=find_father(father[i]);
    relation[i]=(relation[i]+relation[t]+1)%2;
    return father[i];
}

void merge(int a,int b)
{
    int x,y;
    x=find_father(a);
    y=find_father(b);
    father[x]=y;
    relation[x]=(relation[b]-relation[a])%2;
}

int main()
{
    int t,i,j,n,m,a,b,flag;
    scanf("%d",&t);
    for(j=1; j<=t; j++)
    {
        flag=0;
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
        {
            father[i]=i;
            relation[i]=1;
        }
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            if(find_father(a)==find_father(b))
            {
                if(relation[a]==relation[b])//说明是同性
                {
                    flag=1;
                }
            }
            else merge(a,b);
        }
        if(flag)
            printf("Scenario #%d:\nSuspicious bugs found!\n\n",j);
        else
            printf("Scenario #%d:\nNo suspicious bugs found!\n\n",j);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值