How many integers can you find
Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4950 Accepted Submission(s): 1416
Problem Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2 2 3
Sample Output
7
Author
wangye
简单容斥题目,求能被m个数中的任何一个数整除的数的集合,因为n个数是小于n的,所以乘法时为n-1,同时要排除0的影响
#include<cstdio>
#include<cstring>
int n,m;
int ans = 0;
int a[105],t = 0;
int gcd(int x,int y){
while(y){
int t = x%y;
x = y;
y = t;
}
return x;
}
void dfs(int now,int cnt,int x){
x = a[now]/gcd(x,a[now])*x;
if(cnt & 1)
ans += (n-1)/x;
else
ans -= (n-1)/x;
for(int i = now+1;i < t;i ++){
dfs(i,cnt+1,x);
}
}
int main(){
while(~scanf("%d%d", &n, &m)){
t = 0;
ans = 0;
for(int i = 0;i < m;i ++){
int x;
scanf("%d", &x);
if(x) a[t++] = x;
}
for(int i = 0;i < t;i ++){
dfs(i,1,a[i]);
}
printf("%d\n", ans);
}
return 0;
}