HDU1796 How many integers can you find[容斥定理]


D - How many integers can you find
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7


题意:

找出 1-N里面能与集合M中任意一个整除的数的个数


容斥原理   如果M集合中有0 直接不要

然后用二进制来选择 M的个数  算出选择的数的最小公倍数 再用(n-1)去找出个数 

因为题目中不包括n  选择的数的个数是奇数就加上  选择的数的个数是偶数就减去


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int N=15;
int num[N];
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
ll lcm(ll a,ll b)
{
    return a/gcd(a,b)*b;
}
int main()
{
    ll n,m;
    while (~scanf("%lld%lld",&n,&m))
    {
        int cnt=0;
        for (int i=0 ; i<m ; i++)
        {
            int x;
            scanf("%d",&x);
            if (x)
                num[cnt++]=x;
        }
        ll res=0;
        for (int i=1 ; i<(1<<cnt) ; i++)
        {
            int s=0;
            ll sum=1;
            for (int j=0 ; j<cnt ; j++)
            {
                if (i>>j&1)
                {
                    sum=lcm(sum,(ll)num[j]);//最小公倍数
                    s++;
                    if (sum>n)
                        break;
                }
            }
            if (s&1)
                res+=(n-1)/sum;//题目中不包括n 所以从n-1计算
            else
                res-=(n-1)/sum;
        }
        printf("%lld\n",res);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值