Regionals 2014 >> Latin America 6822 - Black a

6822
Black and white stones
Shagga and Dolf like to play a game with stones, each of which is either black or white. At the beginning
of the game, Dolf arranges all the stones in a single line from left to right. Then, Shagga’s goal is to
reorder the stones so that all the black stones are to the left of all the white stones. To do this, he
can choose any pair of stones of different color and swap their positions, paying A coins to Dolf in the
process. However, if the two stones whose positions he is swapping are adjacent, Dolf must give him a
refund of B coins, meaning that the operation will effectively cost Shagga only A − B coins.
Shagga is not very bright, so he hasn’t realized yet that he will only loose coins while playing this
game. However, he is aware of his limitations, so he knows that if he played optimally he would loose
fewer coins than he is loosing right now, with his strategy of randomly choosing the stones he swaps in
each movement. Therefore, he wants to know the minimum number of coins he will have to pay Dolf
in order to get to the desired arrangement of stones, and is threatening to feed you to the goats if you
don’t help him.
Input
The input contains several test cases; each test case is formatted as follows. The first line contains two
integers A and B (0 ≤ B < A ≤ 106), representing respectively the cost of swapping two stones and
the value of the refund when swapping adjacent stones. The second line contains a non-empty string
S of at most 5000 characters. The i-th character of S indicates the color of the i-th stone, from left to
right, in the initial arrangement of the stones. The character is either the uppercase letter ‘B’ or the
uppercase letter ‘W’, indicating respectively a black or a white stone.
Output
For each test case in the input, output a line with an integer representing the minimum number of coins
Shagga will have to pay Dolf in order to arrange the stones such that all the black ones are to the left
of all the white ones.
Sample Input
2 1
BWWB
5 3
WBWWBWBWBWBBBWWBBB
1000000 0
W
Sample Output
2
27

0


题意:把所有的黑色(B)移到左边、白色(W)移到右边的最小花费。每交换,花费为a,若交换的为相邻位置则只需花费a-b

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
#include <vector>
using namespace std;

typedef long long ll;
#define MAX 20005
#define PI acos(-1.0)
ll min(ll a,ll b){
	if(a > b) return b;
	else return a;
}
ll f[50005]; //在此位置前(包含自己)有多少个B 
ll cnt[50005]; //在第i个B前有多少个W 
int main(){
	ll a,b;
	while(~scanf("%lld%lld", &a, &b)){
		string s;
		cin >> s;
		ll len = (ll)s.size();
		ll tot = 0;
		b = a-b;
		memset(f,0,sizeof(f));
		memset(cnt,0,sizeof(cnt));
		int n = 1;
		for(ll i = 0;i < len;i++){
			if(s[i] == 'B'){
				f[i] = 1;
				cnt[n] = tot;
				n ++;
			}
			else{
				cnt[n] = ++tot;
			}
		}
		n --;
		for(ll i = 1;i < len;i++) f[i] += f[i-1];
		for(ll i = 1;i <= n;i++) cnt[i] += cnt[i-1];
		ll mmin = b*cnt[n];
		for(ll i = 0;i < len;i++){
			if(s[i] == 'W'){
				ll tmp = i+1-f[i];  //在此i前有多少个W(包括自己) 
				if(n-tmp-f[i] < 0) break;  //注意跳出 
				//cout << mmin << " " << tmp*a << " " << b << " " << cnt[n-tmp]-cnt[f[i]] << " " << n-tmp-f[i] << endl;
				mmin = min(mmin,tmp*a+b*(cnt[n-tmp]-cnt[f[i]]-tmp*(n-tmp-f[i])));
			}
		}

		printf("%lld\n", mmin);
	}
	return 0;
}
/*4 3
BWWWWWBWBWBWWBWBWBWWWB
6 2
BWWBWBWWWBWBBBBW
*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值