Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
Hint
Huge input, scanf is recommended.
单调栈
如果当前矩形高度比栈顶大,直接入栈
如果小,一直出栈并记录出栈矩阵的宽度,宽度乘其高度更新最大值,然后入栈以其高,总宽的矩形
#include <cstdio>
#include <iostream>
using namespace std;
using ll = long long;
const int maxn = 1e5 + 5;
ll high[maxn], width[maxn], s[maxn];
int main()
{
int n;
while (~scanf("%d", &n) && n)
{
for (int i = 1; i <= n; ++i)
scanf("%d", &high[i]);
high[n + 1] = 0;//最后加一个0防止操作完栈中还有矩阵
ll l = 0, ans = 0;
for (int i = 1; i <= n + 1; ++i)
{
if (high[i] > s[l])
{
s[++l] = high[i];
width[l] = 1;//记录宽度
}
else
{
ll w = 0;
while (s[l] > high[i])
{
w += width[l];
ans = max(ans, w * s[l]);
--l;
}
s[++l] = high[i];
width[l] = w + 1;//入栈高high[i],宽w+1的矩形
}
}
printf("%lld\n", ans);
}
return 0;
}