A - Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO
 
 
 
 
刚开始看到这道题时大部分人会想到用for循环来完成,但是肯定会超时的,所以我们就想到用二分法来完成,这虽然是一道二分的简单题,把二分法学会会用其实是很困难的。该题还要注意到flag的用法。
 
 
 
 
  
  
#include <iostream>
#include <cstdio>
#include<algorithm>
using namespace std;

const int MAX=500+5;
int arr[MAX*MAX];
int k,flag;

void bs(int x)
{
    int left,right,mid;
    left=0,right=k-1;      
    while(left<=right)
    {
        mid=(left+right)>>1;     //要比单纯的(left+right)/2快很多
        if(arr[mid]>x)
            right=mid-1;
        else if(arr[mid]<x)
            left=mid+1;
        else
        {
            flag=1;
            return;
        }
    }
    return;
}

int main()
{
    int L,N,M,Case=1;
    while(~scanf("%d%d%d",&L,&N,&M))
    {
        int a[MAX],b[MAX],c[MAX],T,x;

        for(int i=0;i<L;i++)
           scanf("%d",&a[i]);
        for(int i=0;i<N;i++)
            scanf("%d",&b[i]);
        for(int i=0;i<M;i++)
            scanf("%d",&c[i]);

        k=0;
        for(int i=0;i<L;i++)
            for(int j=0;j<N;j++)
            arr[k++]=a[i]+b[j];        //本题的二分主要用在这儿把数组a[i]的和fa数组b[i]又

        sort(arr,arr+k);
        scanf("%d",&T);
        printf("Case %d:\n",Case++);
        while(T--)
        {
            flag=0;
            scanf("%d",&x);
            for(int i=0;i<M;i++)
            {
                 bs(x-c[i]);
                 if(flag)
                 {
                  printf("YES\n");
                  break;
                 }
            }
            if(!flag)
            printf("NO\n");
        }

    }

    return 0;
}
    
    

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值