题解: HDU 2141 Can you find it? (二分查找)

上题目

Time Limit:3000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u

Description Give you three sequences of numbers A, B, C, then we give
you a number X. Now you need to calculate if you can find the three
numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the
first line there are three integers L, N, M, in the second line there
are L integers represent the sequence A, in the third line there are N
integers represent the sequences B, in the forth line there are M
integers represent the sequence C. In the fifth line there is an
integer S represents there are S integers X to be calculated. 1<=L, N,
M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form
“Case d:”, then for the S queries, you calculate if the formula can be
satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output Case 1: NO YES NO

分析

给定A B C 三个数组 求能否在三个数组中分别找到一个数,使得他们的和是给定的K

我们将表达式变形得 A + B = K - C;

这样我们只需要将A + B 求出来 然后枚举c 二分查找 A + B

枚举的时间复杂度 N
二分的时间复杂度logN

时间复杂度 O(NlogN)

上代码

#include <stdio.h>  
#include <algorithm>  
#include <string.h>  
using namespace std;

__int64 a[505], b[505], c[505], la, lb, lc;
__int64 sum[505 * 505], len;

int bin(__int64 x)
{
    __int64 l = 0, r = len - 1;
    while (l <= r)
    {
        __int64 mid = (l + r) >> 1;
        if (sum[mid] == x)
            return 1;
        else if (sum[mid]>x)
            r = mid - 1;
        else
            l = mid + 1;
    }
    return 0;
}

int main()
{
    __int64 m, s, cas = 1, i, j, k;
    while (~scanf("%I64d%I64d%I64d", &la, &lb, &lc))
    {
        for (i = 0; i<la; i++)
            scanf("%I64d", &a[i]);
        for (i = 0; i<lb; i++)
            scanf("%I64d", &b[i]);
        for (i = 0; i<lc; i++)
            scanf("%I64d", &c[i]);
        sort(c, c + lc);
        len = 0;
        for (i = 0; i<la; i++)
        {
            for (j = 0; j<lb; j++)
            {
                sum[len++] = a[i] + b[j];
            }
        }
        sort(sum, sum + len);
        len = unique(sum, sum + len) - sum;
        scanf("%I64d", &m);
        printf("Case %I64d:\n", cas++);
        while (m--)
        {
            scanf("%I64d", &s);
            if (s>sum[len - 1] + c[lc - 1] || s<sum[0] + c[0])
            {
                printf("NO\n");
                continue;
            }
            __int64 flag = 0;
            for (i = 0; i<lc; i++)
            {
                int kk = s - c[i];
                if (bin(kk))
                {
                    flag = 1;
                    break;
                }
            }
            if (flag)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值