Harmonic Number (II) LightOJ - 1245 (找规律)

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

 long long H( int n ) 
 {
        long long res = 0;
        for( int i = 1; i <= n; i++ )
            res = res + n / i;
        return res;
    }

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.
Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 2^31).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

题意:

根据题中所给代码,可知该题是求 n/1+n/2+n/3+…+n/n 的和。

思路:
基于题目上给出的数据过大,使用题中所给代码超时是必然的,所以我们需要更改一下这个求解方法,降低运行时间,多算几项找规律吧!
在这里插入图片描述
总结公式就是2 * [ (n/1+n/2+…+n/sqrt(n) ] - [ sqrt(n)*sqrt(n) ] ,自己也动手推算一下吧!

代码:

#include<stdio.h>
#include<math.h>
int main()
{
    int t;
    long long n;
    int k=0;
    scanf("%d",&t);
    while(t--)
    {
        k++;
        int i;
        long long s,s1=0;
        scanf("%lld",&n);
 
        s=(int)sqrt(n);
        for(i=1;i<=s;i++)
            s1=s1+n/i;
        s1=s1*2;
        s1=s1-s*s;
        printf("Case %d: %lld\n",k,s1);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值