Frogger POJ - 2253(最短路+Floyd+计算两点间距离)

该博客介绍了一个计算两蛙之间最短距离的问题,使用了Floyd算法来找出Freddy Frog从其所在石头到达Fiona Frog石头的最短路径。题目中给出了每只青蛙石头的坐标,并通过若干个中转石头来确定最小跳跃范围,即Frog Distance。代码示例展示了如何应用Floyd算法解决此类问题,并输出结果到三位小数。
摘要由CSDN通过智能技术生成

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:

Freddy Frog要到Fiona Frog的位置,两蛙分别在两个石头上,坐标为n行中的前两行,求Freddy Frog能到Fiona Frog位置的最短距离

思路:

n最大为200,Floyd算法可以用,计算两点间距离,赋值给dis [ i ] [ j ] ,双向路,即dis [ i ] [ j ] =dis [ j ] [ i ] 之后套模板即可

代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
double dis[210][210];//注意数组开double 距离是double型
struct node
{
    double a;
    double b;
} s[210];
int n,k=0;
void floyd() //模板
{
    for(int k=1; k<=n; k++)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                dis[i][j]=min(dis[i][j],max(dis[i][k],dis[k][j]));
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(dis,0,sizeof(dis));
        k++;
        for(int i=1; i<=n; i++)
        {
            scanf("%lf %lf",&s[i].a,&s[i].b);
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                //dis[i][j]=dist(s[i].a,s[i].b,s[j].a,s[j].b);
                dis[i][j]=dis[j][i]=sqrt((s[i].a-s[j].a)*(s[i].a-s[j].a)+(s[i].b-s[j].b)*(s[i].b-s[j].b));
            }
        }
        floyd();
        if(k>1)
            printf("\n");
        printf("Scenario #%d\n",k);
        printf("Frog Distance = %.3f\n",dis[1][2]);

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值