[kuangbin]专题四 最短路练习 Frogger POJ - 2253【dijkstra/floyd】

【题目描述】
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
青蛙Freddy坐在湖中央的一块石头上。突然他注意到青蛙Fiona坐在另一个石头上。他计划去找她,但是因为水很脏并且全是游客的防晒霜,他想避免游泳并通过跳接近她。
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
不幸的是,青蛙Fiona的石头在他跳跃范围之外。因此Freddy想用其他石头作停留并通过连续的跳跃接近她。
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
要执行给定的跳跃序列,青蛙的跳跃范围显然必须至少与该序列中发生的最长跳长相同。
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
青蛙距离(人类也称其为最小最大距离)在两块石头之间,因此被定义为两块石头之间所有可能的路径之间的最小必要跳跃范围。
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
你得到了Freddy的石头,Fiona的石头和湖中所有其他石头的坐标。你的工作是计算Freddy和Fiona的石头之间的青蛙距离。

【输入】
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
输入将会包含一个或多个样例。第一行包含一个整数n(2<=n<=200),后面n行每行包含两个整数 xi,yi (0 <= xi,yi <= 1000) 表示第i块石头的坐标。1号石头是Freddy的石头,2号石头是Fiona的石头,另外的n-2块石头未被占用。每组测试样例之间有一个空行,输入以n的零(0)值结束。

【输出】
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
对于每个样例,输出一行 “Scenario #x"和一行"Frog Distance = y” ,其中x表示测试样例的序号(从1开始),y表示适当的实数,打印成三个小数。在每个测试用例之后,即使在最后一个测试用例之后,也要放一个空行。

【样例输入】
2
0 0
3 4

3
17 4
19 4
18 5

0

【样例输出】
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目链接:https://cn.vjudge.net/problem/POJ-2253

做法1
代码如下(dijkstra模板变形):

#include <iostream>
#include <iomanip>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
static const int MAXN=200;
double E[MAXN+10][MAXN+10],d[MAXN+10];
int n,x[MAXN+10],y[MAXN+10];
bool vis[MAXN+10];
void dijkstra()
{
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++)
        d[i]=1e9;
    d[1]=0;
    for(int i=1;i<n;i++)
    {
        int x=0;
        for(int j=1;j<=n;j++)
            if(!vis[j] && (x==0 || d[j]<d[x]))
                x=j;
        vis[x]=true;
        for(int y=1;y<=n;y++)
            d[y]=min(d[y],max(d[x],E[x][y]));
    }
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int kase=0;
    while(cin>>n && n)
    {
        for(int i=1;i<=n;i++)
            cin>>x[i]>>y[i];
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                E[i][j]=1e9;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                E[i][j]=min(E[i][j],sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])));
                E[j][i]=E[i][j];
            }
        dijkstra();
        cout<<"Scenario #"<<++kase<<endl;
        cout<<"Frog Distance = "<<fixed<<setprecision(3)<<d[2]<<endl;
        cout<<endl;
    }
    return 0;
}

做法2
代码如下(floyd变形):

#include <iostream>
#include <iomanip>
#include <cmath>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
static const int MAXN=200;
double E[MAXN+10][MAXN+10];
int x[MAXN+10],y[MAXN+10];
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int n,kase=0;
    while(cin>>n && n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i==j) E[i][j]=0;
                else E[i][j]=INF;
        for(int i=1;i<=n;i++)
            cin>>x[i]>>y[i];
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                E[i][j]=min(E[i][j],sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])));
                E[j][i]=E[i][j];
            }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    E[i][j]=min(E[i][j],max(E[i][k],E[k][j]));
        cout<<"Scenario #"<<++kase<<endl;
        cout<<"Frog Distance = "<<fixed<<setprecision(3)<<E[1][2]<<endl;
        cout<<endl;
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值