POJ 2566 BOUND FOUND 尺取法

题目:
Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15 
方法:看到一连串的数字,分段求和,第一反应就是求前缀和。第二就是尺取法,具体见程序
//By Sean Chen
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#define M 0x3f3f3f3f     //尽可能大,因为把M定义为100000不够大而WA了一次
using namespace std;

struct data{
    int sum,pos;
};
data add[100005];
int a,n,k,target,startpos,endpos;

int cmp(data a,data b)
{
    return a.sum<b.sum;
}

void swap(int &a,int &b)
{
    int temp=a;
    a=b;
    b=temp;
    return;
}

void findans(int t)      //尺取法
{
    int left=0,right=1,Min=M,temps,ansleft,ansright,ansvalue;
    while (left<=n && right<=n && Min!=0)
    {
        temps=add[right].sum-add[left].sum;
        //cout<<temps<<' '<<left<<' '<<right<<endl;
        if (abs(temps-t)<Min)
        {
            ansleft=add[left].pos;
            ansright=add[right].pos;
            ansvalue=temps;
            Min=abs(temps-t);
        }
        if (temps>t)           //现在的和大于目标,左指针右移
            left++;
        if (temps<t)            //现在的和小于目标,右指针右移,和增大
            right++;
        if (temps==t)
            break;
        if (left==right)       //当两个指针重叠时,右指针右移
            right++;
    }
    if (ansleft>ansright)         
        swap(ansleft,ansright);
    printf("%d %d %d\n",ansvalue,ansleft+1,ansright);
    return;
}

int main()
{
    scanf("%d%d",&n,&k);
    while (n && k)
    {
        memset(add,0,sizeof(add));
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            add[i].pos=i;
            add[i].sum=add[i-1].sum+a;      //求前缀和
        }
        sort(add,add+n+1,cmp);       //前缀和从小到大排序
        /*for (int i=0;i<=n;i++)
            printf("%d ",add[i].sum);
        cout<<endl;*/
        while (k--)
        {
            scanf("%d",&target);
            findans(target);
        }
        scanf("%d%d",&n,&k);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值