Catch That Cow(抓住那头牛)


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
#define Max 100000
int visited[Max];
struct Way{
	int x;
	int time;
	Way(int x1,int time1)
	{
		x=x1;
		time=time1;
	}
};
int main()
{
	ios::sync_with_stdio(false);
	int N,K;
	memset(visited,0,sizeof(visited));
	queue <Way> cow;
	cin>>N>>K;
	cow.push(Way(N,0));
	visited[N]=1;
	while(!cow.empty())
	{
		Way s=cow.front();
		if(s.x==K)
		{
			cout<<s.time<<endl;
			break;
		}
		else
		{
			if(s.x-1>=0&&!visited[s.x-1])//左移一位 
			{
				cow.push(Way(s.x-1,s.time+1));
				visited[s.x-1]=1;
			}
			if(s.x+1<=Max&&!visited[s.x+1])//右移一位 
			{
				cow.push(Way(s.x+1,s.time+1));
				visited[s.x+1]=1;
			}
			if(s.x*2<=Max&&!visited[s.x*2])//直接到达2*x点 
			{
				cow.push(Way(s.x*2,s.time+1));
				visited[s.x*2];
			}
		}
		cow.pop();
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值