哈希算法---YY's new problem

Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i  1], P[i  2], P[i  3] that 
P[i  1]-P[i  2]=P[i  2]-P[i  3], 1<=i  1<i  2<i  3<=N.
Input
The first line is T(T<=60), representing the total test cases. 
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
Output
For each test case, just output 'Y' if such i  1, i  2, i  3 can be found, else 'N'.
Sample Input
2
3
1 3 2
4
3 2 4 1
Sample Output
N
Y

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int num[10007];
int Hash[10007];
int main()
{
	int T,N;
	int sum,flag;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N);
		memset(num,0,sizeof(num));
		memset(Hash,0,sizeof(Hash));
		flag=0;
		for(int i=0;i<N;i++)
		{
			scanf("%d",&num[i]);
			Hash[num[i]]=i;		//根据数据出现的先后次序来 标记 
		}
		for(int i=0;i<N;i++)
		{
			for(int j=i+1;j<N;j++)
			{
				sum=num[i]+num[j];
				if(sum%2) continue;
				else if(Hash[sum/2]>i&&Hash[sum/2]<j)
				{ 
					flag=1;
					break;
				}
			}
			if(flag==1)
				break;
		}
		if(flag==1)	printf("Y\n");
		else printf("N\n");
	}
	return 0;
 } 


Time limit
4000 ms
Memory limit
65536 kB
OS
Windows
Status Accepted
Time 3104ms
Memory 1640kB
Length 648
Lang G++
Submitted

















































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值