POJ3268 Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Status Accepted
Time 188ms
Memory 4688kB
Length 1840
Lang G++
Submitted
题目大意:

首先有N头牛来自1-N个农场,它们要去X农场参加派对,如今有多种路径供它选择,所有路径都是单向的,所以返程路线和前往路线不一样,有M条路径供它选择,选择出前往路线和返回路线总长度最短的。

输入

N M X

从N到X去,总共M条路线

接下来有M行路线,起点+终点+权值

输出

输出最短路径长度

解题思路:

建立两个路径长度数组。

1.第一条是从X出发能到达所有农场的最短路径长度。

dist1[i]=map[X][i];

判断条件:

if(dist1[j]>(dist1[k]+map[k][j])&&!vis[j])

dist1[j]=dist1[k]+map[k][j];

2.第二条是从i农场出发能到达X的最短路径长度。

dist2[i]=map[i][X];

判断条件:

if(dist2[j]>(dist2[k]+map[j][k])&&!vis[j])

dist2[j]=dist2[k]+map[j][k];

综上所述,进行画龙点睛之笔。因为题目要求最长时间花费为多少。

for(i=1;i<=n;i++)
if(dist1[i]+dist2[i]>length)
length=dist1[i]+dist2[i];

坑点总结:

1.首先题目首先理解要到位,开始理解成从N到X找一条最短路,从X到N找一条最短路,两个相加即可。后来发现题目要求是从1-N分别找出到X 与X到1-N的最短路里面二者相加最长的那条路。

2. dist1[i]=map[X][i];dist2[i]=map[i][X];注意此处的X不可以换成N,因为目的地是X,起初的理解是从1-N可以到X去,也就可以从X到1-X去,但是明显是错误的。

3.千万千万记住要访问标记,千万千万不要i j变量循环套用乱用,否则坑到爆炸。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 1<<30
#define MAX 1007
int dist1[MAX],dist2[MAX];
int map[MAX][MAX]; 
int N,M,X;
int length=0;
void dijkstra(int n,int v)
{
	int i,j,k,temp;
	bool vis[MAX];
	for(i=1;i<=n;i++)
	{
		dist1[i]=map[X][i];
		dist2[i]=map[i][X];
		vis[i]=false;
	}
	for(i=1;i<=n;i++)
	{
		temp=INF;
		for(j=1;j<=n;j++)
		{
			if(temp>dist1[j]&&!vis[j])
			{
				k=j;
				temp=dist1[j];
			}
		}
		vis[k]=true;
		//cout<<k<<endl;
		for(j=1;j<=n;j++)
		{
			if(dist1[j]>(dist1[k]+map[k][j])&&!vis[j])
				dist1[j]=dist1[k]+map[k][j];
		}
		/*for(j=1;j<=n;j++)
			cout<<dist1[j]<<" ";
		cout<<endl;*/
	}
	for(i=1;i<=n;i++)
		vis[i]=false;
	for(i=1;i<=n;i++)
	{
		temp=INF;
		for(j=1;j<=n;j++)
		{
			if(temp>dist2[j]&&!vis[j])
			{
				k=j;
				temp=dist2[j];
			}
		}
		vis[k]=true;
		//cout<<k<<endl;
		for(j=1;j<=n;j++)
		{
			if(dist2[j]>(dist2[k]+map[j][k])&&!vis[j])
				dist2[j]=dist2[k]+map[j][k];
		}
		/*for(j=1;j<=n;j++)
			cout<<dist2[j]<<" ";
		cout<<endl;*/
	}
	length=-1;
	for(i=1;i<=n;i++)
		if(dist1[i]+dist2[i]>length)
			length=dist1[i]+dist2[i];
	/*length=dist1[n]+dist2[n];*/
	cout<<length<<endl;
}
int main()
{
	int i,j,k,x,y;
	cin>>N>>M>>X;
	for(i=1;i<=N;i++)
		for(j=1;j<=N;j++)
		{
			if(i==j)
				map[i][j]=0;
			else
				map[i][j]=INF;
		}
			
	for(i=1;i<=M;i++)
	{
		cin>>x>>y;
		cin>>map[x][y];
	}
	/*for(i=1;i<=N;i++)
	{
		for(j=1;j<=N;j++)
			cout<<map[i][j]<<" ";
		cout<<endl;
	}*/
	dijkstra(N,X);	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值