Farthest Nodes in a Tree

题目描述:

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

输入:

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

输出:

For each case, print the case number and the maximum distance.

样例输入:

2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50

样例输出:

Case 1: 100
Case 2: 80

也看了其他的相关博客,可能是我的理解能力不好,实在是不知道为什么加上head[ ]指向就可以完成搜索了,越看越懵
就用vector写了一篇,应该属于比较容易理解的了,本蒟蒻相当懒惰,代码风格可能有点粗糙,没有什么注释,提交过了就粘贴过来了
代码如下:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
typedef pair<int,int> P;
vector<P> feng[30005];
int ans;
int d[30005];
int wei;
int visit[30005];
void bfs(int start)
{
	queue<int> que;
	que.push(start);
	memset(d,0,sizeof(d));
	memset(visit,0,sizeof(visit));
	visit[start]=1;
	while(!que.empty())
	{
		int where=que.front();
		que.pop();
		for(int i=0;i<feng[where].size();i++)
		{
			if(d[feng[where][i].first]<d[where]+feng[where][i].second&&visit[feng[where][i].first]==0)
			{
				d[feng[where][i].first]=d[where]+feng[where][i].second;
				if(ans<d[feng[where][i].first])
				{
					ans=d[feng[where][i].first];
					wei=feng[where][i].first;
//					printf("%d %d %d %d\n",ans,where,feng[where][i].first,d[where]);
				}
				visit[feng[where][i].first]=1;
				que.push(feng[where][i].first);
			}
		}
	}
}
int main()
{
	int kk=1;
	int ttt;
	scanf("%d",&ttt);
	while(ttt--)
	{
		int n;
		scanf("%d",&n);
		ans=0;
		int a,b,c;
		for(int i=0;i<=n;i++)
		{
			feng[i].clear();
		}
		for(int i=1;i<n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			feng[a].push_back(P(b,c));
			feng[b].push_back(P(a,c));
		}
		bfs(0);
		bfs(wei); 
		printf("Case %d: %d\n",kk++,ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值