find the longest of the shortest

题目描述:

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

输入:

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

输出:

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

样例输入:

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

样例输出:

11
13
27

题目大意:

m条路,去掉其中某一条路可分别得到一个最短路,求这些最短路中的最大值

code:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
typedef pair<int,int> P;
const int inf=99999999;
int a[2005][2005];
int d[2005];
int visit[2005];
int father[2004];
queue<P> que;
int n,m;
void djstera(int start)
{
	fill(d,d+n+5,inf);
	memset(visit,0,sizeof(visit));
	d[start]=0;
	while(1)
	{
		int v=-1;
		for(int i=1;i<=n;i++)
		{
			if(!visit[i]&&(v==-1||d[i]<d[v]))
				v=i;
		} 
		if(v==-1)break;
		visit[v]=1;
		for(int i=1;i<=n;i++)
		{
			if(d[i]>d[v]+a[v][i])
			{
				d[i]=d[v]+a[v][i];
				father[i]=v;
			}
		}
	}
}
int main()
{
	int tt=1;
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=1;i<=n;i++)
		{
			father[i]=i;
			for(int j=1;j<=n;j++)
			{
				if(i==j)a[i][j]=0;
				else a[i][j]=inf;
			}
		}
		int xx,yy,zz;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&xx,&yy,&zz);
			a[xx][yy]=a[yy][xx]=zz;
		}
		djstera(1);
		int what=n;
		while(1)
		{
			if(father[what]==what)
			{
				break;
			}
			else
			{
				que.push(P(father[what],what));
				what=father[what];
			}
		}//找到那个最短路的路径
		int ans=0;
		while(!que.empty())
		{
			P p=que.front();
			que.pop();
			int cun=a[p.first][p.second];
			a[p.first][p.second]=inf;
			djstera(1);
			ans=max(d[n],ans);
			a[p.first][p.second]=cun;
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值